Security home

 

Home / mailingsPDF  

[RHSA-2018:2371-01] Moderate: Red Hat OpenShift Application Runtimes

Posted on 09 August 2018
RedHat

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
Red Hat Security Advisory

Synopsis: Moderate: Red Hat OpenShift Application Runtimes security and bug fix update
Advisory ID: RHSA-2018:2371-01
Product: Red Hat OpenShift Application Runtimes
Advisory URL: https://access.redhat.com/errata/RHSA-2018:2371
Issue date: 2018-08-09
CVE Names: CVE-2018-12537 CVE-2018-12540
=====================================================================

1. Summary:

An update is now available for Red Hat OpenShift Application Runtimes.

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Description:

Red Hat Openshift Application Runtimes provides an application platform
that reduces the complexity of developing and operating applications
(monoliths and microservices) for OpenShift as a containerized platform.

The RHOAR Eclipse Vert.x 3.5.3 release serves as a replacement for RHOAR
Eclipse Vert.x 3.5.1, and includes bug fixes and enhancements. For a
detailed list of issues resolved in the community Eclipse Vert.x 3.5.3
release, see the release notes in the References section.

Security Fix(es):

* vertx: Improper neutralization of CRLF sequences allows remote attackers
to inject arbitrary HTTP response headers (CVE-2018-12537)

* vertx-web: Incomplete CSRF validation by CSRFHandler (CVE-2018-12540)

For more details about the security issue(s), including the impact, a CVSS
score, and other related information, refer to the CVE page(s) listed in
the References section.

3. Solution:

Before applying the update, back up your existing installation, including
all applications, configuration files, databases and database settings, and
so on.

The References section of this erratum contains a download link (you must
log in to download the update).

4. Bugs fixed (https://bugzilla.redhat.com/):

1591072 - CVE-2018-12537 vertx: Improper neutralization of CRLF sequences allows remote attackers to inject arbitrary HTTP response headers
1600666 - CVE-2018-12540 vertx-web: Incomplete CSRF validation by CSRFHandler

5. References:

https://access.redhat.com/security/cve/CVE-2018-12537
https://access.redhat.com/security/cve/CVE-2018-12540
https://access.redhat.com/security/updates/classification/#moderate
https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?downloadType=distributions&product=catRhoar.eclipse.vertx&version=3.5.3
https://access.redhat.com/documentation/en-us/red_hat_openshift_application_runtimes/1/html-single/red_hat_openshift_application_runtimes_release_notes/

6. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2018 Red Hat, Inc.

 

TOP

Mailings :

Exploits :