Security home

 

Home / mailingsPDF  

[SECURITY] [DSA 4267-1] kamailio security update

Posted on 08 August 2018
Debian Security Advisory

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-4267-1 security@debian.org
https://www.debian.org/security/ Salvatore Bonaccorso
August 08, 2018 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : kamailio
CVE ID : CVE-2018-14767

Henning Westerholt discovered a flaw related to the To header processing
in kamailio, a very fast, dynamic and configurable SIP server. Missing
input validation in the build_res_buf_from_sip_req function could result
in denial of service and potentially the execution of arbitrary code.

For the stable distribution (stretch), this problem has been fixed in
version 4.4.4-2+deb9u2.

We recommend that you upgrade your kamailio packages.

For the detailed security status of kamailio please refer to its
security tracker page at:
https://security-tracker.debian.org/tracker/kamailio

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org

 

TOP

Mailings :

Exploits :