ext4 disk 4TB not mounting

Post Reply
Peter_w
Posts: 5
Joined: Mon Aug 04, 2008 7:43 pm

ext4 disk 4TB not mounting

Post by Peter_w »

Hi,

i have a 4TB in a PC with 1 big partition.
It was created with parted as 1 big partition.

However the PC fell without power and crashed,
and now the disk is not mounting.

I checked the disk with

Code: Select all

sudo e2fsck /dev/sdc1
and I don't have any errors.

I get the following error:

Code: Select all

mount -t ext4 /dev/sdc /mnt/test/
mount: wrong fs type, bad option, bad superblock on /dev/sdc,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
dmesg :

Code: Select all

[ 1056.180415] EXT4-fs (sdc): VFS: Can't find ext4 filesystem
[ 1056.180617] FAT-fs (sdc): bogus number of reserved sectors
[ 1056.180631] FAT-fs (sdc): Can't find a valid FAT filesystem
[ 1066.299788] EXT4-fs (sdc): VFS: Can't find ext4 filesystem
What is strange is when I use gdisk /dev/sdc :

Code: Select all

 Partition GUID code: EB-----------------------7 ([b]Microsoft basic data[/b])
Partition unique GUID: 3C-----------------4C
First sector: 2048 (at 1024.0 KiB)
Last sector: 7814035455 (at 3.6 TiB)
Partition size: 7814033408 sectors (3.6 TiB)
Attribute flags: 0000000000000000
Partition name: 'primary'
When I'm sure it is a linux partition with ext4.


Anyone got any ideas ?
Chris
Site Admin
Posts: 122
Joined: Mon Jul 21, 2008 9:45 am
Location: Leuven, Belgium
Contact:

Re: ext4 disk 4TB not mounting

Post by Chris »

I think your mount command is wrong,
you should mount the partition, not the drive.

Code: Select all

mount -t ext4 /dev/sdc1 /mnt/test/
For the type Microsoft basic data,
It don't think it pose a problem.

You can change the type with gdisk:

Code: Select all

sudo gdisk /dev/sdc
t change a partition's type code

And change it to the default ( 8300 )

let us know if you still have problems.
Post Reply